use strict;
my $str = '/research/the-123s-of-school-choice/
';
my $regex = qr/\/research\//mp;
my $subst = '\\/research-library/?report=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";