const regex = new RegExp('\\/research\\/', 'gm')
const str = `/research/the-123s-of-school-choice/
`;
const subst = `\/research-library/?report=`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);