// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/research\/").unwrap();
let string = "/research/the-123s-of-school-choice/
";
let substitution = "\\/research-library/?report=";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}