import Foundation
let pattern = #"\/research\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/research/the-123s-of-school-choice/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\/research-library/?report="#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)