#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d\d?)\/(\d\d?)\/(\d{4})"
Local $sString = "01/02/2018" & @CRLF & _
"1/2/2018" & @CRLF & _
"" & @CRLF & _
"01/2/2018 " & @CRLF & _
"// if we put (\d\d?)\/(\d\d+)\/(\d{4}) the month should be 10,11,12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")