using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\d?)\/(\d\d?)\/(\d{4})";
string input = @"01/02/2018
1/2/2018
01/2/2018
// if we put (\d\d?)\/(\d\d+)\/(\d{4}) the month should be 10,11,12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}