import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\d?)\\/(\\d\\d?)\\/(\\d{4})";
final String string = "01/02/2018\n"
+ "1/2/2018\n\n"
+ "01/2/2018 \n"
+ "// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}