use strict;
my $str = '01/02/2018
1/2/2018
01/2/2018
// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12';
my $regex = qr/(\d\d?)\/(\d\d?)\/(\d{4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}