re = /(\d\d?)\/(\d\d?)\/(\d{4})/m
str = '01/02/2018
1/2/2018
01/2/2018
// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end