// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d\d?)\/(\d\d?)\/(\d{4})").unwrap();
let string = "01/02/2018
1/2/2018
01/2/2018
// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}