const regex = /(\d\d?)\/(\d\d?)\/(\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d?)\\\/(\\d\\d?)\\\/(\\d{4})', 'gm')
const str = `01/02/2018
1/2/2018
01/2/2018
// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}