$re = '/(\d\d?)\/(\d\d?)\/(\d{4})/m';
$str = '01/02/2018
1/2/2018
01/2/2018
// if we put (\\d\\d?)\\/(\\d\\d+)\\/(\\d{4}) the month should be 10,11,12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);