package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\d?)\/(\d\d?)\/(\d{4})`)
var str = `01/02/2018
1/2/2018
01/2/2018
// if we put (\d\d?)\/(\d\d+)\/(\d{4}) the month should be 10,11,12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}