# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\*\s+\*+\s+\$Log.*?\*\///s;t' <<< "/*
other comment
*/
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/"