import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*\\s+\\*+\\s+\\$Log.*?\\*/";
final String string = "/* \n"
+ "other comment\n"
+ "*/\n\n"
+ "/*\n"
+ "******************************************************************\n"
+ "$Log: oldfile.c,v $\n"
+ "Revision 11.4 2000/01/20 19:01:41 userid\n"
+ "blah blah blah\n\n"
+ "*/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}