# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/\*\s+\*+\s+\$Log.*?\*/"
test_str = ("/* \n"
"other comment\n"
"*/\n\n"
"/*\n"
"******************************************************************\n"
"$Log: oldfile.c,v $\n"
"Revision 11.4 2000/01/20 19:01:41 userid\n"
"blah blah blah\n\n"
"*/")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.