re = /\/\*\s+\*+\s+\$Log.*?\*\//
str = '/*
other comment
*/
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result