import Foundation
let pattern = #"/\*\s+\*+\s+\$Log.*?\*/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
/*
other comment
*/
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}