package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)/\*\s+\*+\s+\$Log.*?\*/`)
var str = []byte(`/*
other comment
*/
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}