use strict;
my $str = '/*
other comment
*/
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/';
my $regex = qr//\*\s+\*+\s+\$Log.*?\*//sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";