#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)/\*\s+\*+\s+\$Log.*?\*/"
Local $sString = "/* " & @CRLF & _
"other comment" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"******************************************************************" & @CRLF & _
"$Log: oldfile.c,v $" & @CRLF & _
"Revision 11.4 2000/01/20 19:01:41 userid" & @CRLF & _
"blah blah blah" & @CRLF & _
"" & @CRLF & _
"*/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)