const regex = new RegExp('/\\*\\s+\\*+\\s+\\$Log.*?\\*/', 's')
const str = `/*
other comment
*/
/*
******************************************************************
\$Log: oldfile.c,v \$
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);