# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)(#\w+)/$1<a href="\/hash\/$2" class='hash_tag'>$2<\/a>/gm;t' <<< "test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don't take this -> l'#09
Don't take this -> » or '"