use strict;
my $str = 'test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don\'t take this -> l\'#09
Don\'t take this -> » or '';
my $regex = qr/(^|\s)(#\w+)/mp;
my $subst = '$1<a href="/hash/$2" class=\'hash_tag\'>$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";