#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\s)(#\w+)"
Local $sString = "test" & @CRLF & _
"" & @CRLF & _
"Take this #test" & @CRLF & _
"" & @CRLF & _
"#test <- take this" & @CRLF & _
"" & @CRLF & _
"take this #test another word" & @CRLF & _
"" & @CRLF & _
"take this #Mest another word" & @CRLF & _
"" & @CRLF & _
"Don't take this -> l'#09" & @CRLF & _
"" & @CRLF & _
"Don't take this -> » or '"
Local $sSubst = "$1<a href="/hash/$2" class='hash_tag'>$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)