import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s)(#\\w+)";
final String string = "test\n\n"
+ "Take this #test\n\n"
+ "#test <- take this\n\n"
+ "take this #test another word\n\n"
+ "take this #Mest another word\n\n"
+ "Don't take this -> l'#09\n\n"
+ "Don't take this -> » or '";
final String subst = "$1<a href=\"/hash/$2\" class='hash_tag'>$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}