import Foundation
let pattern = ##"(^|\s)(#\w+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don't take this -> l'#09
Don't take this -> » or '
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<a href="/hash/$2" class='hash_tag'>$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)