re = /(^|\s)(#\w+)/m
str = 'test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don\'t take this -> l\'#09
Don\'t take this -> » or ''
subst = '$1<a href="/hash/$2" class=\'hash_tag\'>$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result