// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|\s)(#\w+)").unwrap();
let string = "test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don't take this -> l'#09
Don't take this -> » or '";
let substitution = "$1<a href=\"/hash/$2\" class='hash_tag'>$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}