# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\s)(#\w+)"
test_str = ("test\n\n"
"Take this #test\n\n"
"#test <- take this\n\n"
"take this #test another word\n\n"
"take this #Mest another word\n\n"
"Don't take this -> l'#09\n\n"
"Don't take this -> » or '")
subst = "$1<a href=\"/hash/$2\" class='hash_tag'>$2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.