using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)(#\w+)";
string substitution = @"$1<a href=""/hash/$2"" class='hash_tag'>$2</a>";
string input = @"test
Take this #test
#test <- take this
take this #test another word
take this #Mest another word
Don't take this -> l'#09
Don't take this -> » or '";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}