#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+"
Local $sString = " <h6 class="other-projects__title">другие проекты хабра</h6>" & @CRLF & _
" <ul class="other-projects__list">" & @CRLF & _
" <li class="other-projects__item">" & @CRLF & _
" <a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">" & @CRLF & _
" Хабр" & @CRLF & _
" </a>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="other-projects__item">" & @CRLF & _
" <a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">" & @CRLF & _
" Карьера" & @CRLF & _
" </a>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="other-projects__item">" & @CRLF & _
" <a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">" & @CRLF & _
" Фриланс" & @CRLF & _
" </a>" & @CRLF & _
" </li>" & @CRLF & _
" </ul>" & @CRLF & _
"<a\s+[hH][rR][eE][fF]\s*="https?:\/\/voximplant\.com[^"]+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")