use strict;
my $str = ' <h6 class="other-projects__title">другие проекты хабра</h6>
<ul class="other-projects__list">
<li class="other-projects__item">
<a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Хабр
</a>
</li>
<li class="other-projects__item">
<a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">
Карьера
</a>
</li>
<li class="other-projects__item">
<a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Фриланс
</a>
</li>
</ul>
<a\\s+[hH][rR][eE][fF]\\s*="https?:\\/\\/voximplant\\.com[^"]+';
my $regex = qr/<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}