$re = '/<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+/m';
$str = ' <h6 class="other-projects__title">другие проекты хабра</h6>
<ul class="other-projects__list">
<li class="other-projects__item">
<a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Хабр
</a>
</li>
<li class="other-projects__item">
<a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">
Карьера
</a>
</li>
<li class="other-projects__item">
<a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Фриланс
</a>
</li>
</ul>
<a\\s+[hH][rR][eE][fF]\\s*="https?:\\/\\/voximplant\\.com[^"]+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);