package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+`)
var str = ` <h6 class="other-projects__title">другие проекты хабра</h6>
<ul class="other-projects__list">
<li class="other-projects__item">
<a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Хабр
</a>
</li>
<li class="other-projects__item">
<a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">
Карьера
</a>
</li>
<li class="other-projects__item">
<a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Фриланс
</a>
</li>
</ul>
<a\s+[hH][rR][eE][fF]\s*="https?:\/\/voximplant\.com[^"]+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}