// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+"#).unwrap();
let string = " <h6 class=\"other-projects__title\">другие проекты хабра</h6>
<ul class=\"other-projects__list\">
<li class=\"other-projects__item\">
<a href =\"https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel\">
Хабр
</a>
</li>
<li class=\"other-projects__item\">
<a href=\"https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel\">
Карьера
</a>
</li>
<li class=\"other-projects__item\">
<a Href=\"voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel\">
Фриланс
</a>
</li>
</ul>
<a\\s+[hH][rR][eE][fF]\\s*=\"https?:\\/\\/voximplant\\.com[^\"]+";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}