import Foundation
let pattern = #"<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h6 class="other-projects__title">другие проекты хабра</h6>
<ul class="other-projects__list">
<li class="other-projects__item">
<a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Хабр
</a>
</li>
<li class="other-projects__item">
<a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">
Карьера
</a>
</li>
<li class="other-projects__item">
<a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Фриланс
</a>
</li>
</ul>
<a\s+[hH][rR][eE][fF]\s*="https?:\/\/voximplant\.com[^"]+
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)