import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+[hH][rR][eE][fF]\\s*=\\s*\"(?:https?:\\/\\/)?voximplant\\.com[^\"]+";
final String string = " <h6 class=\"other-projects__title\">другие проекты хабра</h6>\n"
+ " <ul class=\"other-projects__list\">\n"
+ " <li class=\"other-projects__item\">\n"
+ " <a href =\"https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel\">\n"
+ " Хабр\n"
+ " </a>\n"
+ " </li>\n"
+ " <li class=\"other-projects__item\">\n"
+ " <a href=\"https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel\">\n"
+ " Карьера\n"
+ " </a>\n"
+ " </li>\n"
+ " <li class=\"other-projects__item\">\n"
+ " <a Href=\"voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel\">\n"
+ " Фриланс\n"
+ " </a>\n"
+ " </li>\n"
+ " </ul>\n"
+ "<a\\s+[hH][rR][eE][fF]\\s*=\"https?:\\/\\/voximplant\\.com[^\"]+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}