using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+[hH][rR][eE][fF]\s*=\s*""(?:https?:\/\/)?voximplant\.com[^""]+";
string input = @" <h6 class=""other-projects__title"">другие проекты хабра</h6>
<ul class=""other-projects__list"">
<li class=""other-projects__item"">
<a href =""https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel"">
Хабр
</a>
</li>
<li class=""other-projects__item"">
<a href=""https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel"">
Карьера
</a>
</li>
<li class=""other-projects__item"">
<a Href=""voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel"">
Фриланс
</a>
</li>
</ul>
<a\s+[hH][rR][eE][fF]\s*=""https?:\/\/voximplant\.com[^""]+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}