const regex = /<a\s+[hH][rR][eE][fF]\s*=\s*"(?:https?:\/\/)?voximplant\.com[^"]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s+[hH][rR][eE][fF]\\s*=\\s*"(?:https?:\\\/\\\/)?voximplant\\.com[^"]+', 'gm')
const str = ` <h6 class="other-projects__title">другие проекты хабра</h6>
<ul class="other-projects__list">
<li class="other-projects__item">
<a href ="https://voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Хабр
</a>
</li>
<li class="other-projects__item">
<a href="https://career.habr.com?utm_source=habr_qna&utm_medium=habr_top_panel">
Карьера
</a>
</li>
<li class="other-projects__item">
<a Href="voximplant.com/?utm_source=habr_qna&utm_medium=habr_top_panel">
Фриланс
</a>
</li>
</ul>
<a\\s+[hH][rR][eE][fF]\\s*="https?:\\/\\/voximplant\\.com[^"]+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}