#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S+?)\/(\S+?)\/?$"
Local $sString = "/a/b" & @CRLF & _
"/a/b/" & @CRLF & _
"/document/data/" & @CRLF & _
"/document/data" & @CRLF & _
"/docs/article1/" & @CRLF & _
"/docs/article1"
Local $sSubst = "$1/$2.md"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)