const regex = /(\S+?)\/(\S+?)\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+?)\\\/(\\S+?)\\\/?$', 'gm')
const str = `/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1`;
const subst = `$1/$2.md`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);