// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S+?)\/(\S+?)\/?$").unwrap();
let string = "/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1";
let substitution = "$1/$2.md";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}