import Foundation
let pattern = #"(\S+?)\/(\S+?)\/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2.md"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)