using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+?)\/(\S+?)\/?$";
string substitution = @"$1/$2.md";
string input = @"/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}