re = /(\S+?)\/(\S+?)\/?$/m
str = '/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1'
subst = '$1/$2.md'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result