import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+?)\\/(\\S+?)\\/?$";
final String string = "/a/b\n"
+ "/a/b/\n"
+ "/document/data/\n"
+ "/document/data\n"
+ "/docs/article1/\n"
+ "/docs/article1";
final String subst = "$1/$2.md";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}