$re = '/(\S+?)\/(\S+?)\/?$/m';
$str = '/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1';
$subst = "$1/$2.md";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;