import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "For .+EachIn .+;";
final String string = " foreach (var VARIABLE in COLLECTION)\n"
+ " {\n"
+ " \n"
+ " }\n\n"
+ " For Local tUiObj ob=EachIn tScreen.Active().sub;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}