import Foundation
let pattern = #"For .+EachIn .+;"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foreach (var VARIABLE in COLLECTION)
{
}
For Local tUiObj ob=EachIn tScreen.Active().sub;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)